欢迎光临
我们一直在努力

易语言数组 去掉3个以上相同的 保留其它 源码

易语言数组 去掉3个以上相同的 保留其它 源码-军哥驿站

.版本 2

.子程序 _按钮1_被单击
.局部变量 临时数组, 文本型, , “0”
.局部变量 计次, 整数型
.局部变量 内部数组, 文本型, , “0”
.局部变量 内部计次, 整数型

临时数组 = 分割文本 (编辑框1.内容, #换行符, )
.计次循环首 (取数组成员数 (临时数组), 计次)
文本_逐字分割 (临时数组 [计次], 内部数组)
.计次循环首 (取数组成员数 (内部数组), 内部计次)
.判断开始 (数组_取次数 (内部数组, 内部数组 [内部计次]) ≥ 3)
临时数组 [计次] = “0”
到循环尾 ()
.默认

.判断结束

.计次循环尾 ()
.计次循环尾 ()
.计次循环首 (取数组成员数 (临时数组), 计次)
.判断开始 (临时数组 [计次] ≠ “0”)
编辑框2.加入文本 (临时数组 [计次] + #换行符)
.默认

.判断结束

.计次循环尾 ()

支付宝扫码打赏 微信扫码打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者

未经允许不得转载:军哥驿站 » 易语言数组 去掉3个以上相同的 保留其它 源码

分享到:更多 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

军哥驿站 建站更专业 更方便

咨询vip会员联系军哥