欢迎光临
我们一直在努力

做易语言程序自动更新用到的代码记录一下

.版本 2

.子程序 _按钮1_被单击
.局部变量 字节集, 字节集
.局部变量 取出的文本, 文本型
.局部变量 最新版本, 文本型

字节集 = 网页_访问 (“http://xxxx.com/0dd7da31.html”)
' 输出调试文本 (到文本 (字节集))
取出的文本 = 文本_取出中间文本 (到文本 (字节集), “============================================================================================”, “============================================================================================”)
.如果真 (取出的文本 = “”)
信息框 (“网络错误请重试”, 0, )
返回 ()
.如果真结束

取出的文本 = 子文本替换 (取出的文本, “</p><p>”, #换行符, , , 真)
取出的文本 = 子文本替换 (取出的文本, “<br />”, #换行符, , , 真)
取出的文本 = 子文本替换 (取出的文本, “&nbsp;”, “”, , , 真)

写到文件 (目录_取临时目录 () + “UpDate_Config.ini”, 到字节集 (取出的文本))
最新版本 = 读配置项 (目录_取临时目录 () + “UpDate_Config.ini”, “版本”, “测试版”, “0”)
.如果真 (到数值 (最新版本) > 到数值 (#常量_主程序版本))
运行 (取运行目录 () + “\UpDate.exe UpDate N”, 假, )

支付宝扫码打赏 微信扫码打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者

未经允许不得转载:军哥驿站 » 做易语言程序自动更新用到的代码记录一下

分享到:更多 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

军哥驿站 建站更专业 更方便

阿里云精选联系我们