欢迎光临
我们一直在努力

易语言超级列表框导入

.版本 2
.支持库 edroptarget
.支持库 iext

拖放对象1.接收文件 = 真
拖放对象1.zc拖放控件 (超级列表框1.取窗口句柄 ())

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型
.局部变量 局_内容, 文本型
.局部变量 局_数组, 文本型, , "0"
.局部变量 局_计次, 整数型
.局部变量 局_索引, 整数型

局_内容 = 到文本 (读入文件 (接收到的文件路径))
局_数组 = 分割文本 (局_内容, 字符(10), )
.计次循环首 (取数组成员数 (局_数组), 局_计次)
    .如果真 (局_数组 [局_计次] ≠ “”)
        局_索引 = 超级列表框1.插入表项 (, 到文本 (超级列表框1.取表项数 () + 1), , , , )
        超级列表框1.置标题 (局_索引, 1, 局_数组 [局_计次])
    .如果真结束

.计次循环尾 ()
支付宝扫码打赏 微信扫码打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者

未经允许不得转载:军哥驿站 » 易语言超级列表框导入

分享到:更多 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

军哥驿站 建站更专业 更方便

咨询vip会员联系军哥