欢迎光临
我们一直在努力

易语言数组取不重复元素代码

.版本 2

.子程序 数组_整数取不重复元素, , 公开, 排序后,再循环去删除所有重复的
.参数 原数组, 整数型, 参考 数组, 传入要处理的数组
.参数 新数组, 整数型, 参考 数组, 返回处理的结果
.局部变量 遍历位置, 整数型
.局部变量 成员数, 整数型
.局部变量 到底重复几个, 整数型

清除数组 (新数组)

数组排序 (原数组, 真)
成员数 = 取数组成员数 (原数组)
遍历位置 = 1
.判断循环首 (遍历位置 ≤ 成员数)
    .如果真 (遍历位置 = 成员数)  ' 不然会丢失最后一个
        加入成员 (新数组, 原数组 [遍历位置])
        返回 ()
    .如果真结束

    .如果 (原数组 [遍历位置] = 原数组 [遍历位置 + 1])
        到底重复几个 = 2
        .如果真 (遍历位置 + 1 + 到底重复几个 - 1 = 成员数 + 1)
            返回 ()
        .如果真结束
        .判断循环首 (原数组 [遍历位置 + 1] = 原数组 [遍历位置 + 1 + 到底重复几个 - 1])
            到底重复几个 = 到底重复几个 + 1
        .判断循环尾 ()
        遍历位置 = 遍历位置 + 到底重复几个
    .否则
        ' --------------------------------------------
        加入成员 (新数组, 原数组 [遍历位置])
        遍历位置 = 遍历位置 + 1
    .如果结束

.判断循环尾 ()

效果:{10,2,3,5,6,6,6,6,6,2,3,9}

处理后是

{5,9,10}

支付宝扫码打赏 微信扫码打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者

未经允许不得转载:军哥驿站 » 易语言数组取不重复元素代码

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

军哥驿站 建站更专业 更方便

联系我们