欢迎光临
我们一直在努力

易语言数组去重复文本型

在论坛看到的:数组去重复文本型

.版本 2

.子程序 数组_去重复_文本型, 整数型, , 返回剩余不重复数组的成员数量
.参数 文本数组, 文本型, 数组, 要去重复的 文本数组
.参数 返回数组, 文本型, 可空 数组
.局部变量 计次1, 整数型
.局部变量 计次2, 整数型
.局部变量 数组, 文本型, , "0"
.局部变量 文本判断, 逻辑型

.计次循环首 (取数组成员数 (文本数组), 计次1)
    文本判断 = 假
    .计次循环首 (取数组成员数 (数组), 计次2)
        .如果真 (数组 [计次2] = 文本数组 [计次1])
            文本判断 = 真
        .如果真结束

    .计次循环尾 ()
    .如果真 (文本判断 = 假)
        加入成员 (数组, 文本数组 [计次1])
    .如果真结束

.计次循环尾 ()
返回数组 = 数组
返回 (取数组成员数 (数组))
支付宝扫码打赏 微信扫码打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者

未经允许不得转载:军哥驿站 » 易语言数组去重复文本型

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

军哥驿站 建站更专业 更方便

联系我们