欢迎光临
我们一直在努力

羊了个羊易语言内存取token源码

精易论坛里面看到的源码

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

输出调试文本 (Yang_GetToken ())

.子程序 Yang_GetToken, 文本型, 公开
.局部变量 内存, 类_内存
.局部变量 Pid, 整数型, , "0"
.局部变量 结果, 整数型, , "0"
.局部变量 Token, 文本型
.局部变量 i, 整数型
.局部变量 n, 整数型

.如果真 (进程_取ID数组 (“WeChatAppEx.exe”, Pid, ) = 0)
    进程_取ID数组 (“WeChatApp.exe”, Pid, )
.如果真结束
.计次循环首 (取数组成员数 (Pid), i)
    .如果真 (Pid <i> = 0)
        返回 (“”)
    .如果真结束
    内存.搜索 (Pid <i>, 到字节集 (“\” + #引号 + “,\” + #引号 + “token\” + #引号 + “:\” + #引号), 结果)
    .计次循环首 (取数组成员数 (结果), n)

        Token = 文本_取出中间文本 (内存.读文本 (Pid <i>, 结果 [n], 1024), “\” + #引号 + “,\” + #引号 + “token\” + #引号 + “:\” + #引号, “\” + #引号 + “,\” + #引号, , )
        .如果真 (Token ≠ “”)
            返回 (Token)
        .如果真结束

    .计次循环尾 ()
.计次循环尾 ()
返回 (“”)
支付宝扫码打赏 微信扫码打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者

未经允许不得转载:军哥驿站 » 羊了个羊易语言内存取token源码

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

军哥驿站 建站更专业 更方便

联系我们